Freifunk/Aufteilen Lan Ports

Aus Wiki CCC Göttingen
Wechseln zu: Navigation, Suche

This software is published under the know-what-you're-doing licence:

  1. you may use this software for whatever you want, given that you know what you're doing.
  2. author of this software isn't responsible for anything since you knew what you're doing.
  3. if you have still questions, chances are you do not fullfill requirements


841 v9 teilen der Lan-Ports

danach ist dann 1,2 Mesh 3,4 Client

das ganze scheint updatefest zu sein .... getestet mit: https://github.com/freifunk-gluon/gluon/commit/172ad68134d91699144a6b762c2c8dbf2b5af518

ACHTUNG so kommt man nicht mehr in den Config MODE !!!

root@ffgoe60e3275ffd06:/etc/config# diff network.org network -u
--- network.org 2015-10-28 14:00:27.000000000 +0100
+++ network     2015-10-28 14:01:35.000000000 +0100
@@ -23,7 +23,13 @@
 config switch_vlan
        option device 'switch0'
        option vlan '1'
-       option ports '0 1 2 3 4'
+       option ports '0t 1 2'
+
+config switch_vlan             
+        option device 'switch0'
+        option vlan '2'        
+        option ports '0t 3 4'
+               
 
 config interface 'wan'
        option igmp_snooping '0'
@@ -51,7 +57,7 @@
        option reqprefix 'no'
        option proto 'dhcpv6'
        list ifname 'bat0'
-       list ifname 'eth0'
+       list ifname 'eth0.1'
        option igmp_snooping '0'
        option macaddr '60:e3:27:5f:fd:06'
        option peerdns '1'
@@ -79,8 +85,8 @@
        option proto 'batadv'
 
 config interface 'mesh_lan'
-       option ifname 'eth0'
-       option auto '0'
+       option ifname 'eth0.2'
+       option auto '1'
        option macaddr '62:e4:28:5f:fd:06'
        option mesh 'bat0'
        option proto 'batadv'
root@ffgoe60e3275ffd06:/etc/config#